[PATCH] D80130: [mlir][SystemZ] Fix incompatible datalayout in SystemZ

Alex Zinenko via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 18 09:40:04 PDT 2020


ftynse requested changes to this revision.
ftynse added a comment.
This revision now requires changes to proceed.

Thanks! I only have a nit about variable naming.



================
Comment at: mlir/lib/ExecutionEngine/ExecutionEngine.cpp:123
   }
-  std::unique_ptr<llvm::TargetMachine> machine(
-      target->createTargetMachine(targetTriple, "generic", "", {}, {}));
+  std::string CPU = std::string(llvm::sys::getHostCPUName());
+  llvm::SubtargetFeatures Features;
----------------
MLIR uses `camelBack` for variables, please change the names


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80130/new/

https://reviews.llvm.org/D80130





More information about the llvm-commits mailing list