[PATCH] D76869: [Clang] Restore replace_path_prefix instead of startswith
Sylvain Audi via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 6 07:30:08 PDT 2020
saudi updated this revision to Diff 262368.
saudi added a comment.
Renamed the argument `PrefixStyle` to `style`.
Not that it matches the rest of other arguments declared in Path.h, however it doesn't follow the LLVM code guidelines.
`replace_path_prefix` is currently the only function there with CamelCase arguments `OldPrefix` and `NewPrefix`.
Should-I rename those to `oldPrefix` and `newPrefix` to be more homogenous with the rest of the file?
I suppose the other choice would be to rename the style parameter, e.g. `Style St`
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76869/new/
https://reviews.llvm.org/D76869
Files:
clang/lib/CodeGen/CGDebugInfo.cpp
clang/lib/Lex/PPMacroExpansion.cpp
clang/test/Preprocessor/Inputs/include-file-test/file_test.h
clang/test/Preprocessor/file_test.c
clang/test/Preprocessor/file_test.h
clang/test/Preprocessor/file_test_windows.c
llvm/include/llvm/Support/Path.h
llvm/lib/DWARFLinker/DWARFLinker.cpp
llvm/lib/MC/MCContext.cpp
llvm/lib/Support/Path.cpp
llvm/unittests/Support/Path.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D76869.262368.patch
Type: text/x-patch
Size: 12693 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200506/7cf5d1f2/attachment.bin>
More information about the llvm-commits
mailing list