[PATCH] D76711: [AArch64][SVE] Add some integer DestructiveBinaryComm* patterns
Cameron McInally via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon May 4 09:05:19 PDT 2020
cameron.mcinally marked an inline comment as done.
cameron.mcinally added a comment.
> As we previously discussed offline, this design will need a rethink at some point because it is a bit rigid and it could be generalized to handle more cases than zeroing predication. However we can leave that for later.
Ok, no problem. If you'd like to hold off on this project, I can switch to something else.
================
Comment at: llvm/lib/Target/AArch64/SVEInstrFormats.td:2349
+ DestructiveInstTypeEnum flags,
+ string revname="", bit isOrig=0> {
+ let DestructiveInstType = flags in {
----------------
sdesmalen wrote:
> nit: `isOrig` is a bit of a misnomer. Would `isReverse` maybe be more descriptive? (which would have the opposite meaning of `isOrig`)
>
That seems reasonable. I don't really have a strong opinion on it.
To be clear, I should update isOrig everywhere? E.g. SVEPseudo2Instr, getSVERevInstr, getSVEOrigInstr?
If so, that should probably be a separate patch since there are other multiclasses currently using it.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76711/new/
https://reviews.llvm.org/D76711
More information about the llvm-commits
mailing list