[PATCH] D78106: [CSInfo][NFC] Interpret loaded parameter value separately

David Stenberg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 30 04:11:11 PDT 2020


dstenb accepted this revision.
dstenb added a comment.
This revision is now accepted and ready to land.

One minor comment about singular/plural phrasing. Otherwise this looks good to me!



================
Comment at: llvm/lib/CodeGen/AsmPrinter/DwarfDebug.cpp:643
+/// Interpret the value loaded into register by \p CurMI.
+static void interpretValue(const MachineInstr *CurMI,
+                           FwdRegWorklist &ForwardedRegWorklist,
----------------
As an instruction may produce multiple register values, maybe this should be called `interpretValues`, and the comment above updated to reflect that?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D78106/new/

https://reviews.llvm.org/D78106





More information about the llvm-commits mailing list