[PATCH] D79125: Rename NamedAttributeList to MutableDictionaryAttr BEGIN_PUBLIC Rename NamedAttributeList to MutableDictionaryAttr

River Riddle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 29 14:33:46 PDT 2020


rriddle accepted this revision.
rriddle added inline comments.
This revision is now accepted and ready to land.


================
Comment at: mlir/include/mlir/IR/FunctionSupport.h:532
   auto curAttr = getArgAttrDict(index);
-  NamedAttributeList attrList(curAttr);
+  MutableDictionaryAttr attrList(curAttr);
   attrList.set(name, value);
----------------
Not critical, but can we rename these attrList variables?


================
Comment at: mlir/include/mlir/IR/Operation.h:286
 
   /// Set the attribute list on this operation.
+  /// Using a MutableDictionaryAttr is more efficient as it does not require new
----------------
Can we update this comment?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79125/new/

https://reviews.llvm.org/D79125





More information about the llvm-commits mailing list