[PATCH] D79124: [VFDatabase] Testsuite for scalar functions are vector functions with VF =1
Francesco Petrogalli via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 29 14:33:36 PDT 2020
fpetrogalli added a comment.
Just minor comments.
Thank you.
================
Comment at: llvm/test/Transforms/LoopVectorize/vectorizeVFone.ll:28
declare <2 x double> @__atand2_massv(<2 x double>) #1
attributes #0 = { "target-cpu"="pwr9" }
attributes #1 = { nounwind readnone "vector-function-abi-variant"="_ZGV_LLVM_N2v_atan(__atand2_massv)" }
----------------
You might want to remove this too?
================
Comment at: llvm/test/Transforms/LoopVectorize/vectorizeVFone.ll:29
attributes #0 = { "target-cpu"="pwr9" }
attributes #1 = { nounwind readnone "vector-function-abi-variant"="_ZGV_LLVM_N2v_atan(__atand2_massv)" }
----------------
Also, given that all references to ppc seems to be dropped, maybe rename `__atand2_massv` to `vector_atan`, so you can simplify the `CHECK-NOT:` to check for `call fast <{{[0-9]+}} x double> @{{.*}}atan(`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D79124/new/
https://reviews.llvm.org/D79124
More information about the llvm-commits
mailing list