[PATCH] D78996: [MLIR][LINALG] Convert Linalg to Linalg
Alexander Belyaev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 28 09:06:35 PDT 2020
pifon2a added inline comments.
================
Comment at: mlir/lib/Conversion/LinalgToLinalg/LinalgToLinalg.cpp:74
+
+ rewriter.eraseOp(op);
+ return success();
----------------
shouldn't it be `rewriter.replaceOp(op, <what to replace results with>)`? Please, add a test with two chained Linalg ops.
================
Comment at: mlir/lib/Conversion/LinalgToLinalg/LinalgToLinalg.cpp:103
+
+void TensorLinalgToBufferLinalgPass::runOnOperation() {
+ auto &context = getContext();
----------------
why is the definition of `runOnOperation()` method not inside `TensorLinalgToBufferLinalgPass`? I don't think it improved readability here. Is there some guide that does not allow doing that?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D78996/new/
https://reviews.llvm.org/D78996
More information about the llvm-commits
mailing list