[PATCH] D78753: [MLIR] Add conversion from AtomicRMWOp -> GenericAtomicRMWOp.
Alexander Belyaev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Apr 23 13:34:14 PDT 2020
pifon2a created this revision.
pifon2a added reviewers: flaub, herhut.
Herald added subscribers: llvm-commits, Kayjukh, frgossen, grosul1, Joonsoo, liufengdb, lucyrfox, mgester, arpith-jacob, nicolasvasilache, antiagainst, shauheen, jpienaar, rriddle, mehdi_amini, jfb.
Herald added a reviewer: ftynse.
Herald added a project: LLVM.
pifon2a edited the summary of this revision.
Adding this pattern reduces code duplication. There is no need to have a custom implementation for lowering to llvm.cmpxchg.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D78753
Files:
mlir/lib/Conversion/StandardToLLVM/StandardToLLVM.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D78753.259689.patch
Type: text/x-patch
Size: 7303 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200423/dfacd5ff/attachment.bin>
More information about the llvm-commits
mailing list