[PATCH] D77663: WIP: [MLIR] Lower vector slices while lowering linalg to LLVM.
Pierre Oechsel via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 15 02:41:52 PDT 2020
poechsel marked an inline comment as not done.
poechsel added inline comments.
================
Comment at: mlir/lib/Conversion/VectorToLLVM/ConvertVectorToLLVM.cpp:1120
+void mlir::lowerVectorSlicesToLLVM(Operation *op, MLIRContext *context) {
+ OwningRewritePatternList patterns;
----------------
aartbik wrote:
> nit: slightly more general name, we are packing more and more vector-vector lowerings into this set? (I have another one pending :-)
Actually I think putting these in a separate pass might be a good idea:
- `lowerVectorSlicesToLLVM` already looks like an independent pass (we are first collecting a bunch of patterns and then applying them greedily)
- Testing is also made harder as `lowerVectorSlicesToLLVM` also does dead code elimination.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77663/new/
https://reviews.llvm.org/D77663
More information about the llvm-commits
mailing list