[PATCH] D77786: [AArch64] Add v8.5 Branch Target Identification support.
Momchil Velikov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Apr 9 03:13:37 PDT 2020
chill added inline comments.
================
Comment at: libunwind/src/assembly.h:47
+#elif (defined(__arm64__) || defined(__aarch64__)) && defined(__ARM_FEATURE_BTI_DEFAULT)
+#define PPC64_OPD1 \
+ .pushsection ".note.gnu.property", "a" SEPARATOR \
----------------
This will be emitted for all functions, but we need only one per object file, isn't it ?
Also, could you, please, rename `PPC64OPD{1,2}` to `TARGET_OPD{1,2}`, or `{ARCH ...}`, something like that.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77786/new/
https://reviews.llvm.org/D77786
More information about the llvm-commits
mailing list