[PATCH] D77528: [MLIR] Add support to use aligned_alloc to lower AllocOp from std to llvm

River Riddle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Apr 7 13:36:32 PDT 2020


rriddle added inline comments.


================
Comment at: mlir/lib/Conversion/StandardToLLVM/StandardToLLVM.cpp:1427
+      uint64_t constEltSizeBytes = 0;
+      auto isMallocAlignmentSufficient = [&]() {
+        if (auto vectorType = elementType.template dyn_cast<VectorType>())
----------------
ftynse wrote:
> bondhugula wrote:
> > mehdi_amini wrote:
> > > ftynse wrote:
> > > > nicolasvasilache wrote:
> > > > > bondhugula wrote:
> > > > > > ftynse wrote:
> > > > > > > bondhugula wrote:
> > > > > > > > ftynse wrote:
> > > > > > > > > I wouldn't add a lambda that is only called once immediately after its definition.
> > > > > > > > Hmm... this is just for better readability - it gives a name / auto documents a code block without the need to outline it into a function or add an explicit comment. I've seen this as a standard practice.
> > > > > > > This does not seem to be common practice in MLIR. FWIW, I find it less readable than just writing
> > > > > > > 
> > > > > > > ```
> > > > > > > int64_t constEltSizeBytes = 0;
> > > > > > > if (auto vectorType = elementType.template dyn_cast<VectorType>())
> > > > > > >   constEltSizeBytes =
> > > > > > >       vectorType.getNumElements() *
> > > > > > >       llvm::divideCeil(vectorType.getElementTypeBitWidth(), 8);
> > > > > > > else
> > > > > > >   constEltSizeBytes =
> > > > > > >       llvm::divideCeil(elementType.getIntOrFloatBitWidth(), 8);
> > > > > > > 
> > > > > > > // Use aligned_alloc if elt_size > malloc's alignment.
> > > > > > > bool isMallocAlignmentSufficient = constEltSizeBytes > kMallocAlignment;
> > > > > > > useAlignedAlloc = isMallocAlignmentSufficient;
> > > > > > > ```
> > > > > > > 
> > > > > > > Since you already have the block comment immediately above it anyway, and variables can have names just as well as lambdas. The lambda also mutates a global state that it captures by-reference, so the only effects of lambda are: (1) extra indentation; (2) extra LoC; and (3) extra concepts leading to cognitive overhead.
> > > > > > Hmm... the demarcation/isolation is important I feel. I'm fine with changing to the straightline style but out of curiosity and for future purposes as well, it'll be good to have a third person view here on coding style as far as such patterns go: @mehdi_amini - is there a guideline here?
> > > > > I am generally a fan of such style (esp. when mixed with functional combinators), so I'd vote for +1 it when it makes sense.
> > > > Generally, I would be strongly opposed to defining style guidelines based on a single use of a construct in a single diff, where only a small subset of contributors could participate (and before you can object that review history is public, are you reading all comments on all diffs?). I would be also opposed to having to define additional rules until we have to. I am not generally opposed to helper lambdas, I just don't see any benefit from this specific one, only drawbacks. And a lambda that the entire environment by reference is not exactly my definition of isolation.
> > > @bondhugula this seems too detailed to have a guideline :)
> > > I wouldn't say it is "common", but probably not unheard of?
> > > I have been doing this myself but in general not calling it right after, rather to outline a block of code outside of a loop to make the loop shorter and easier to read, or similar situation (getting large boilerplate out of the way and "naming it").
> > > 
> > > @rriddle ?
> > As Mehdi now confirms, this is too detailed to have a style guideline. The lambda demarcates the start and end of the thing it's naming/auto-documenting - you don't get it from code comments alone and I see it better for readability. Given @ntv's and @mehdi_amini's comments, I'm now strongly inclined to retain it. 
> > The lambda demarcates the start and end of the thing it's naming/auto-documenting - you don't get it from code comments alone and I see it better for readability. 
> 
> Well, you have a block comment right above it (modulo the variable declaration that is only used inside the lambda), so I wouldn't call it auto-documenting since you felt like you needed to write documentation for it. And having a named variable of lambda-type or an identically-named variable of boolean type still gives you exactly the same naming scheme.
> 
> > Given @ntv's and @mehdi_amini's comments, I'm now strongly inclined to retain it.
> 
> I read Mehdi's comment differently:
> 
> > but in general not calling it right after
> 
> > rather to outline a block of code outside of a loop to make the loop shorter
> 
> do not seem to necessarily support your usage here (neither does it contradict).
> 
> Readability is a very subjective thing. I was reading your code for review purposes and this construct did make me lose time and expand more energy than for a straight-line code here, so for me personally it decreased readability. Namely because it (a) mutates an implicitly captured variable and (b) requires to unwrap more abstractions mentally. Anyway, I won't block the commit just because of a stylistic discussion.
> 
> I can suggest an alternative that would address part of my readability concerns:
> 
> ```
> int64_t constEltSizeBytes = [elementType]() {
>   if (auto vectorType = elementType.template dyn_cast<VectorType>())
>     return vectorType.getNumElements() *
>         llvm::divideCeil(vectorType.getElementTypeBitWidth(), 8);
>   else
>     return llvm::divideCeil(elementType.getIntOrFloatBitWidth(), 8);
> }();
> bool isMallocAlignmentSufficient = constEltSizeBytes > kMallocAlignment;
> ```
> 
> This removes implicit by-reference capture, makes it clear that you do not intend for the lambda to be reused (named lambda would be also okay since it doesn't store references anyway, but there's no point), and this way of using lambdas is actually considered a C++11 idiom for comlex constant initialization (https://groups.google.com/a/isocpp.org/g/std-discussion/c/FBjcR4WJlkU/m/nQnsSOziq04J) so one can claim it's "common enough".
FWIWI, there is already a guide on using lamdas for computing predicates:

https://llvm.org/docs/CodingStandards.html#turn-predicate-loops-into-predicate-functions


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77528/new/

https://reviews.llvm.org/D77528





More information about the llvm-commits mailing list