[PATCH] D77076: [InstSimplify] Allow some arithmetic optimizations for add/sub/div/rem look through freeze
Juneyoung Lee via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Apr 6 09:45:09 PDT 2020
aqjune marked 2 inline comments as done.
aqjune added inline comments.
================
Comment at: llvm/lib/Analysis/InstructionSimplify.cpp:127
+/// If it is a freeze instruction, returns its operand
+static Value *StripFreeze(Value *V) {
+ if (auto *FI = dyn_cast<FreezeInst>(V))
----------------
lebedev.ri wrote:
> Hm, do we have precedent naming scheme for things like this?
> Alternative variants could include considered `IgnoreFreeze()` or `SkipFreeze()`.
I think `Value::stripPointerCasts` might be the one, though it starts with a small letter & it is at Value.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77076/new/
https://reviews.llvm.org/D77076
More information about the llvm-commits
mailing list