[PATCH] D73086: [DWARF5] Added support for debug_macro section parsing and dumping in llvm-dwarfdump.
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Mar 30 02:07:49 PDT 2020
jhenderson added inline comments.
================
Comment at: llvm/lib/DebugInfo/DWARF/DWARFContext.cpp:300
+ auto Macro = std::make_unique<DWARFDebugMacro>();
+ auto parseAndDump = [&](DWARFDataExtractor &Data, bool IsMacro) {
+ if (Error Err = Macro->parse(getStringExtractor(), Data, IsMacro))
----------------
SouraVX wrote:
> SouraVX wrote:
> > jhenderson wrote:
> > > `ParseAndDump`. This is a (callable) object, not a function.
> > Sorry, didn't get what you meant here ?
> Is naming not conforming to standard are you referring here `parseAndDump` ?
Right. Lambdas are objects, not functions, and so should follow the variable naming scheme, not the function naming scheme.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D73086/new/
https://reviews.llvm.org/D73086
More information about the llvm-commits
mailing list