[PATCH] D76748: [llvm][Support] Add isZero method for TypeSize. [NFC]

Francesco Petrogalli via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 26 14:08:56 PDT 2020


fpetrogalli added a reviewer: efriedma.
fpetrogalli marked an inline comment as done.
fpetrogalli added a subscriber: efriedma.
fpetrogalli added a comment.

In D76748#1944851 <https://reviews.llvm.org/D76748#1944851>, @sdesmalen wrote:

> LGTM, thanks!
>
> While this patch is quite trivial, for other patches, you may want to add a few more reviewers.


Sure, will do. Added @efriedma for visibility, I'll wait some time before submitting to give them the possibility to comment in case they want to.

Thanks,

Francesco



================
Comment at: llvm/include/llvm/Support/TypeSize.h:153
+  // Returns true if the type size is zero.
+  bool isZero() const { return MinSize == 0; }
+
----------------
sdesmalen wrote:
> nit: I mentioned this to Graham when he first proposed TypeSize, but having this variable named 'MinSize' is a bit odd when you compare with Zero, because in a sense, the minimum size of <anything> is always zero :)
Agree. Shall we rename it to `KnownSize`, and consequently rename the get method to `getKnownSize`?

Thanks for the review!


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D76748/new/

https://reviews.llvm.org/D76748





More information about the llvm-commits mailing list