[PATCH] D76602: [MLIR] Introduce std.alloca op
Uday Bondhugula via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Mar 25 21:07:20 PDT 2020
bondhugula added a comment.
In D76602#1941785 <https://reviews.llvm.org/D76602#1941785>, @dcaballe wrote:
> Thanks for adding the alloca op! Really needed.
> Not sure if you discussed this already but just a nit about the name: any plans on renaming `alloca` and `alloc` so that it's a bit clearer what they model? I find it a bit confusing right now. Some options that came to mind:
> alloca -> salloc, salloca
> alloc -> malloc, malloca, alloc
alloca -> salloca sounds good to me! Note that the 'a' suffix in 'alloca' is for 'automatic' freeing (originating from early Unix's and BSDs and it has always meant allocating from the caller's stack). So, alloc -> malloca, alloca -> salloc would be inconsistent. Since 'alloc' currently doesn't specify where it's from the stack/heap and specifies it's explicitly freed via dealloc, we can leave it like that.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76602/new/
https://reviews.llvm.org/D76602
More information about the llvm-commits
mailing list