[PATCH] D75131: [llvm-objdump][XCOFF][AIX] Implement -r option
Jason Liu via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Mar 20 10:50:36 PDT 2020
jasonliu added inline comments.
================
Comment at: llvm/lib/Object/XCOFFObjectFile.cpp:18-20
+enum { RELOC_OVERFLOW = 65535 };
+enum : uint8_t { FUNCTION_SYM = 0x20, SYM_TYPE_MASK = 0x07 };
+enum : uint16_t { NO_REL_MASK = 0x0001 };
----------------
jasonliu wrote:
> jhenderson wrote:
> > At this point would it just make more sense to make these static constant literals?
> >
> > ```
> > // TODO: Use appropriate naming convention - are these spec-defined, or just local names?
> > static const int RELOC_OVERFLOW = 65535; // Use an appropriate type here.
> > static const uint8_t FUNCTION_SYM = 0x20;
> > static const uint8_t SYM_TYPE_MASK = 0x07;
> > static const uint16_t NO_REL_MASK = 0x0001;
> > ```
> >
> This was a drive-by fix because I touched this line when I want to put in InvalidRelocOffset. Now, it's irrelevant to the current patch, and I will put it to its original state.
Sorry, just realized that NO_REL_MASK is the reason I need to do the drive-by fix and it's still needed. So I will use the static const instead.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D75131/new/
https://reviews.llvm.org/D75131
More information about the llvm-commits
mailing list