[PATCH] D76286: [X86][MC] Support enhanced relaxation for branch align
Kan Shengchen via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Mar 19 22:27:11 PDT 2020
skan marked an inline comment as done.
skan added inline comments.
================
Comment at: llvm/lib/Target/X86/MCTargetDesc/X86AsmBackend.cpp:165
bool allowAutoPadding() const override;
+ bool allowEnhancedRelaxation() const override;
void emitInstructionBegin(MCObjectStreamer &OS, const MCInst &Inst) override;
----------------
LuoYuanke wrote:
> Why not just name it as "allowRelaxing" ? The relax information is eventually be indicated in instruction's .td file, right?
See the description in the summary. Traditional relaxation means the operand's size of instruction may be change (e.g, JCC1->JCC4), but if we allow enhanced relaxtion, we can change the instruction's size by adding prefixes on it. They are different, and the enhanced relaxtion has nothing to do with td file
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76286/new/
https://reviews.llvm.org/D76286
More information about the llvm-commits
mailing list