[PATCH] D76286: [X86][MC] Support enhanced relaxation for branch align
LuoYuanke via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Mar 19 21:56:29 PDT 2020
LuoYuanke added inline comments.
================
Comment at: llvm/lib/Target/X86/MCTargetDesc/X86AsmBackend.cpp:165
bool allowAutoPadding() const override;
+ bool allowEnhancedRelaxation() const override;
void emitInstructionBegin(MCObjectStreamer &OS, const MCInst &Inst) override;
----------------
Why not just name it as "allowRelaxing" ? The relax information is eventually be indicated in instruction's .td file, right?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76286/new/
https://reviews.llvm.org/D76286
More information about the llvm-commits
mailing list