[PATCH] D75809: [lld] Add .clang-tidy to customize readability-identifier-naming.{Member,Parameter,Variable}Case => camelBack
Fangrui Song via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Mar 7 09:43:57 PST 2020
MaskRay updated this revision to Diff 248940.
MaskRay retitled this revision from "[lld] Add .clang-tidy to customize readability-identifier-naming.{Member,Parameter,Variable}Case => camelCase" to "[lld] Add .clang-tidy to customize readability-identifier-naming.{Member,Parameter,Variable}Case => camelBack".
MaskRay edited the summary of this revision.
MaskRay added a comment.
Fix typo: camelCase -> camelBack
The former does not work.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D75809/new/
https://reviews.llvm.org/D75809
Files:
lld/.clang-tidy
Index: lld/.clang-tidy
===================================================================
--- /dev/null
+++ lld/.clang-tidy
@@ -0,0 +1,19 @@
+# Almost identical to the top-level .clang-tidy, except that {Member,Parameter,Variable}Case use camelBack.
+Checks: '-*,clang-diagnostic-*,llvm-*,misc-*,-misc-unused-parameters,-misc-non-private-member-variables-in-classes,readability-identifier-naming'
+CheckOptions:
+ - key: readability-identifier-naming.ClassCase
+ value: CamelCase
+ - key: readability-identifier-naming.EnumCase
+ value: CamelCase
+ - key: readability-identifier-naming.FunctionCase
+ value: camelBack
+ - key: readability-identifier-naming.MemberCase
+ value: camelBack
+ - key: readability-identifier-naming.ParameterCase
+ value: camelBack
+ - key: readability-identifier-naming.UnionCase
+ value: CamelCase
+ - key: readability-identifier-naming.VariableCase
+ value: camelBack
+ - key: readability-identifier-naming.IgnoreMainLikeFunctions
+ value: 1
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D75809.248940.patch
Type: text/x-patch
Size: 1181 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200307/0bffff34/attachment.bin>
More information about the llvm-commits
mailing list