[PATCH] D74133: [compiler-rt] Build with correct ABI (PR38025)
Riyaz V Puthiyapurayil via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Mar 1 13:10:31 PST 2020
RVP updated this revision to Diff 247516.
RVP added a comment.
Incorporates most of the changes suggested by @phosek. Have not inlined the code as suggested by @phosek but the new code seems much clearer and avoids the code duplication from inlining. Specifically, the new diff replaces the previous macro with a function. Earlier, the macro contained a `return()` that was presumably difficult to follow. The cache variable is now called `COMPILER_RT_LIBRARY-${name}-${target}` and is set to either the actual path or `NOTFOUND`. Also, the new diff uses `if(NOT DEFINED .,.,)` to distinguish when the cache variable has not been set versus when the variable is set to `NOTFOUND`.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74133/new/
https://reviews.llvm.org/D74133
Files:
compiler-rt/CMakeLists.txt
compiler-rt/cmake/Modules/AddCompilerRT.cmake
compiler-rt/cmake/Modules/HandleCompilerRT.cmake
compiler-rt/cmake/config-ix.cmake
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D74133.247516.patch
Type: text/x-patch
Size: 6497 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200301/6a857f25/attachment.bin>
More information about the llvm-commits
mailing list