[PATCH] D75333: Refactor to distinguish the reason for not interchanging loops.
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Feb 28 13:24:45 PST 2020
fhahn accepted this revision.
fhahn added a comment.
This revision is now accepted and ready to land.
LGTM, but please wait with the submission until D71689 <https://reviews.llvm.org/D71689> is also approved
================
Comment at: lib/Transforms/Scalar/LoopInterchange.cpp:538
for (unsigned i = SelecLoopId; i > 0; i--) {
- bool Interchanged =
+ LoopInterchangeResult Interchanged =
processLoop(LoopList, i, i - 1, LoopNestExit, DependencyMatrix);
----------------
nit: maybe rename the variable to Result or something.
================
Comment at: lib/Transforms/Scalar/LoopInterchange.cpp:552
#endif
- Changed |= Interchanged;
+ Changed |= (Interchanged == LoopInterchangeResult::Optimized);
}
----------------
nit: no braces needed.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D75333/new/
https://reviews.llvm.org/D75333
More information about the llvm-commits
mailing list