[PATCH] D69891: [VP,Integer,#1] Vector-predicated integer intrinsics

Simon Moll via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Feb 17 01:08:06 PST 2020


simoll added a comment.

In D69891#1876867 <https://reviews.llvm.org/D69891#1876867>, @andrew.w.kaylor wrote:

> In D69891#1871485 <https://reviews.llvm.org/D69891#1871485>, @simoll wrote:
>
> > 5. ** Rename to `llvm.experimental.vp.*` ** - Inserting `experimental` is the preferred way to introduce new intrinsics until they are stable (for technical reasons brought up by @chandlerc -  https://reviews.llvm.org/D69891#1852795 ).
>
>
> I feel like I should mention that I don't know how Chandler feels about the use of "experimental" for these intrinsics. I wasn't trying to claim his approval of my suggestion, merely explaining that I thought the reasoning that led to the current naming of the constrained FP intrinsics probably applied here as well.


Well, to set this straight, i didn't mean to imply Chandler's approval. I just want to document what motivates the `experimental` prefix.

> After I made that suggestion @craig.topper pointed out to me that the "experimental" qualifier has a tendency to never go away. See, for example, vector add/reduce intriniscs. All this is to say that my suggestion is just a suggestion and I could be convinced to drop it if that is the consensus.

How about we stick with `llvm.vp.fadd` and go for `llvm.vp.fadd.v2`, etc when/if the intrinsics are updated?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D69891/new/

https://reviews.llvm.org/D69891





More information about the llvm-commits mailing list