[PATCH] D74544: [MLIR] Add naive fusion of parallel loops.
Alexander Belyaev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Feb 13 23:20:09 PST 2020
pifon2a added inline comments.
================
Comment at: mlir/lib/Transforms/ParallelLoopFusion.cpp:40
+ const OperandRange &rhs) -> bool {
+ for (auto item : llvm::zip(lhs, rhs)) {
+ Value p1, p2;
----------------
rriddle wrote:
> nit: Can you just use std::equal for now?
fair enough :)
================
Comment at: mlir/lib/Transforms/ParallelLoopFusion.cpp:85
+ });
+ bool result = !walkResult.wasInterrupted();
+ return result;
----------------
rriddle wrote:
> nit: Remove this temporary value and just return the result directly. It doesn't really help readability at all.
thanks. It was an artefact from logging that I used to have here when debugging.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74544/new/
https://reviews.llvm.org/D74544
More information about the llvm-commits
mailing list