[PATCH] D74401: [MLIR] Add std.atomic_rmw op
Jeremy Bruestle via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Feb 11 10:51:50 PST 2020
jbruestle requested changes to this revision.
jbruestle added inline comments.
This revision now requires changes to proceed.
================
Comment at: mlir/include/mlir/Dialect/StandardOps/Ops.td:230
+
+ An arbitrary modification can be specified in the body region. The induction
+ variable represents the existing value read from the memref. The body region
----------------
I think you just mean 'block argument' not induction variable here (and below in a few places), since it's not iterating over anything.
================
Comment at: mlir/include/mlir/Dialect/StandardOps/Ops.td:252
+
+ Value getInductionVar() { return getBody()->getArgument(0); }
+
----------------
Maybe rename getInitialValue(), or getLoadedValue() or something similar?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74401/new/
https://reviews.llvm.org/D74401
More information about the llvm-commits
mailing list