[PATCH] D74197: [DebugInfo] Simplify DWARFDebugAddr.
Adrian Prantl via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Feb 7 08:45:50 PST 2020
aprantl added inline comments.
================
Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFDebugAddr.h:65
+ /// a header and consists only of a series of addresses.
+ Error extractPreV5(const DWARFDataExtractor &Data, uint64_t *OffsetPtr,
+ uint16_t CUVersion, uint8_t CUAddrSize);
----------------
Assuming that DWARF 6 doesn't change the format again, this naming scheme will look odd in the future.
How about we call this extractV2() and mention in the comment it is for 2 through 4? I.e., always use the minimum version that introduced the encoding in the name?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74197/new/
https://reviews.llvm.org/D74197
More information about the llvm-commits
mailing list