[PATCH] D73684: [MLIR][Linalg] Lower linalg.generic to ploops.

Alexander Belyaev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 30 05:08:27 PST 2020


pifon2a added inline comments.


================
Comment at: mlir/include/mlir/Dialect/Linalg/Passes.h:38
+/// std.load/std.store accesses.
+std::unique_ptr<OpPassBase<FuncOp>> createConvertLinalgToParallelLoopsPass();
+
----------------
ftynse wrote:
> Given that we have parallel loops to sequential loops, does it make sense to keep Linalg to sequential loops?
Yes, it does. We want to go LHLO->Linalg->Ploops->GPU.


================
Comment at: mlir/include/mlir/Dialect/LoopOps/LoopOps.td:179
   let results = (outs Variadic<AnyType>:$results);
-  let regions = (region SizedRegion<1>:$body);
+  let regions = (region SizedRegion<1>:$region);
+
----------------
ftynse wrote:
> Any specific reason for this rename?  I find "body" to be a better name than 'region".
This is what we have in loop::ForOp. Just wanted to be consistent. I can change both though. I can also change getBody()->body() in ForOp and in ParallelOp.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D73684/new/

https://reviews.llvm.org/D73684





More information about the llvm-commits mailing list