[PATCH] D73573: [AArch64][GlobalISel] Fold G_AND into G_BRCOND
Amara Emerson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jan 28 13:55:41 PST 2020
aemerson accepted this revision.
aemerson added a comment.
This revision is now accepted and ready to land.
LGTM with minor nit.
================
Comment at: llvm/lib/Target/AArch64/AArch64InstructionSelector.cpp:1040
+ return false;
+ uint64_t Mask = Log2_64(static_cast<uint64_t>(MaybeMask->Value));
+
----------------
Nit: when you take the log2 of the mask value, it's no longer a mask but more of a bit position. So this should be named something like Bit or TestedBit etc. It'll help make things clearer when we come to folding in more things like shifts (which I assume is going to be done between here and the branch construction below).
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D73573/new/
https://reviews.llvm.org/D73573
More information about the llvm-commits
mailing list