[PATCH] D73405: [mlir] Add initial support for parsing a declarative operation assembly format

River Riddle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 27 16:42:40 PST 2020


rriddle added inline comments.


================
Comment at: mlir/include/mlir/IR/OpBase.td:1575
+  // Custom format.
+  string format = ?;
+
----------------
antiagainst wrote:
> `format` itself is a bit too broad and can be confusing. What about naming it as something like `asmForm` or `assemblyForm`? This applies to other places; I see you generally use "declarative op format". I think calling it "declarative op assembly form" is more natural and descriptive. WDYT?
SGTM


================
Comment at: mlir/test/mlir-tblgen/op-format-spec.td:2
+// RUN: mlir-tblgen -gen-op-decls -I %S/../../include %s 2>&1 | FileCheck %s
+// --dump-input-on-failure
+
----------------
antiagainst wrote:
> Accidentally breaking the lines? I'm not sure this is gonna work. :)
Oops thanks for the catch. I had this split when I was writing the test and forgot to re-add it.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D73405/new/

https://reviews.llvm.org/D73405





More information about the llvm-commits mailing list