[PATCH] D60582: [IPSCCP] Use ValueLatticeElement instead of LatticeVal (NFCI)
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jan 22 17:59:23 PST 2020
fhahn updated this revision to Diff 239748.
fhahn marked 5 inline comments as done.
fhahn added a comment.
Address Eli's comments:
- change name of isUnknownOrConstant to isOverdefined
- simplify getConstantInt.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D60582/new/
https://reviews.llvm.org/D60582
Files:
llvm/include/llvm/Analysis/ValueLattice.h
llvm/lib/Transforms/Scalar/SCCP.cpp
llvm/test/Transforms/SCCP/ip-constant-ranges.ll
llvm/test/Transforms/SCCP/ipsccp-range-crashes.ll
llvm/test/Transforms/SCCP/ipsccp-range-structs.ll
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D60582.239748.patch
Type: text/x-patch
Size: 36683 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20200123/f3c5ddbf/attachment-0001.bin>
More information about the llvm-commits
mailing list