[PATCH] D72808: [mlir] [VectorOps] Lowering of vector.extract/insert_slices to LLVM IR

Aart Bik via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 22 11:56:05 PST 2020


aartbik marked 2 inline comments as done.
aartbik added a comment.

Hold off on reviewing this CL, since it will be broken up in three.
The final remaining part for the lowering will be super small :=)



================
Comment at: mlir/lib/Conversion/VectorToLLVM/ConvertVectorToLLVM.cpp:1075
+      // Compute the vector offsets by de-linearizing the index.
+      SmallVector<int64_t, 4> vectorOffsets(rank);
+      int64_t linearIndex = i;
----------------
andydavis1 wrote:
> We need a TODO to move this code into a VectorOpsUtils class, we have various versions of it floating around in VectorOps.cp and VectorTransforms.cpp
The TODO is already there, see line 1038


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72808/new/

https://reviews.llvm.org/D72808





More information about the llvm-commits mailing list