[PATCH] D72757: [DebugInfo] Simplify the constructor of DWARFDebugAranges::Range. NFC.

Adrian Prantl via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 15 09:53:46 PST 2020


aprantl accepted this revision.
aprantl added a comment.
This revision is now accepted and ready to land.

Thanks!



================
Comment at: llvm/include/llvm/DebugInfo/DWARF/DWARFDebugAranges.h:38
 
     void setHighPC(uint64_t HighPC) {
       if (HighPC == -1ULL || HighPC <= LowPC)
----------------
We should also get rid of the magic value here.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72757/new/

https://reviews.llvm.org/D72757





More information about the llvm-commits mailing list