[PATCH] D72332: AMDGPU/GlobalISel: Custom legalize v2s16 G_SHUFFLE_VECTOR

Nicolai Hähnle via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 9 06:27:55 PST 2020


nhaehnle added a comment.

This makes sense, but I do have one comment.



================
Comment at: llvm/lib/Target/AMDGPU/AMDGPULegalizerInfo.cpp:1593
 
+static bool shuffleIsInOneReg(const MachineInstr &MI) {
+  SmallVector<int, 2> Mask;
----------------
Given that the function only does what the name implies when the MI is an s16 shuffle, maybe either inline it at the single use site or figure out a better name for it?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D72332/new/

https://reviews.llvm.org/D72332





More information about the llvm-commits mailing list