[PATCH] D72312: [DAGCombine] Fold the (fma -x, y, -z) to -(fma x, y, z)
Simon Pilgrim via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jan 8 04:26:32 PST 2020
RKSimon added inline comments.
================
Comment at: llvm/lib/CodeGen/SelectionDAG/DAGCombiner.cpp:12645
+ if (!TLI.isFNegFree(VT) &&
+ TLI.isNegatibleForFree(SDValue(N, 0), DAG, LegalOperations,
+ ForCodeSize) == 2)
----------------
xbolva00 wrote:
> It would be better if this function returns enum constant to improve readability.
Yeah, thats been a pet peeve of mine as well for a long time - I'll take a look (might be after the release though)
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D72312/new/
https://reviews.llvm.org/D72312
More information about the llvm-commits
mailing list