[PATCH] D52634: [WebAssembly] Use TargetIndex operands in DbgValue to track WebAssembly operands locations

Derek Schuff via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 19 14:30:55 PST 2019


dschuff accepted this revision.
dschuff added a comment.

After thinking a bit more, I'd like to rename `DwarfExpression::addTargetIndexLocation` to `DwarfExpression::addWasmLocation` because basically all of the methods on `DarfExpression` correspond to `DW_OP_foo` operands, so a method for adding `DW_OP_wasm_location` should probably just be called `addWasmLocation`. If we want to later have a utility function to extract some other functionality like converting a TargetIndex, we can always do that in the future when we have another caller.
With that suggestion, this change LGTM


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D52634/new/

https://reviews.llvm.org/D52634





More information about the llvm-commits mailing list