[PATCH] D71462: [llvm-readelf][llvm-readobj] - Reimplement the logic of section flags dumping.
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Dec 16 07:20:41 PST 2019
jhenderson added inline comments.
================
Comment at: llvm/test/tools/llvm-readobj/ELF/section-flags-os-proc.test:1
+# RUN: yaml2obj %s -o %t.o
+# RUN: llvm-readobj -S %t.o | FileCheck --check-prefix=OS-PROC-LLVM %s
----------------
Perhaps a top-level comment explaining that this tests the dumping of flags in the respective regions would be a good idea.
================
Comment at: llvm/test/tools/llvm-readobj/ELF/section-flags-os-proc.test:110-118
+ - Name: .both.flags.mask
+ Type: SHT_PROGBITS
+ ShFlags: 0xFFF00000
+ - Name: .both.flags.lowvalues
+ Type: SHT_PROGBITS
+ ShFlags: 0x10100000
+ - Name: .both.flags.highvalues
----------------
I'd rearrange and rename these to be consistent with the previous os and proc ones above:
```
- Name: .both.flags.low
- Name: .both.flags.high
- Name: .both.flags.mask
```
================
Comment at: llvm/test/tools/llvm-readobj/ELF/section-flags.test:175
Flags: [ SHF_EXCLUDE ]
+ - Name: .unknown
+ Type: SHT_PROGBITS
----------------
.unknown -> unknown for consistency with the other sections.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D71462/new/
https://reviews.llvm.org/D71462
More information about the llvm-commits
mailing list