[PATCH] D71249: [LV] Set name for vector preheader and trip count check blocks
Evgeniy via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Dec 11 20:10:31 PST 2019
ebrevnov added a comment.
In D71249#1779171 <https://reviews.llvm.org/D71249#1779171>, @rengolin wrote:
> This change may conflict with your other two. How are we supposed to review them? Are they a set?
>
> If so, what's the order in which they have to be applied?
Yes there are a dependencies between change sets. Especially this and next one. The order is defined by parent/child relationship and can be found at "Revision Contents" section Stack tab.
> If this is just a naming issue, and the test changes look all related to naming, then I agree with @lebedev.ri.
>
> This should be a suffix to the current name, otherwise you'll end up with multiple %tc.check.N still having to find which branch leads where.
I agree with you guys adding a prefix to existing loop name would produce more descriptive names. Unfortunately, this is not what vectorizer does today. And there was no intention to change that in this patch. I believe change like that will touch LOT of tests.
In fact, this patch just fixes inconsistencies in current naming scheme. Namely it does two things: 1) Introduces "tc.check" name for a block which does trip count checking. 2) Sets 'vector.ph' name for a vector preheader even if existing block is reused.
Note that next patch enables unconditional generation of new vector preheader block thus tc.check & vector.ph blocks will contain only related instructions and nothing else.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D71249/new/
https://reviews.llvm.org/D71249
More information about the llvm-commits
mailing list