[PATCH] D71238: Align non-fused branches within 32-Byte boundary (basic case)

LuoYuanke via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Dec 10 19:58:21 PST 2019


LuoYuanke added a comment.

> I've gone as far as writing a rough draft of textual assembler support.  If folks agree this is helpful, I'll abandon this patch, and post one in that direction.  Any high level suggestions as to syntax?  I see two major options, but definitely welcome suggestions w.r.t. naming/semantics/etc...
> 
> Option 1
> 
> .boundary_align 4
>  jmp foo
> 
> and
> 
> .boundary_align 4
>  .bundle_lock
>  test ...
>  jcc foo
>  .bundle_lock
> 
> Option 2
> 
> Option 1
> 
> .boundary_align 4
>  jmp foo
>  .end_boundary_align
> 
> and
> 
> .boundary_align 4
>  test ...
>  jcc foo
>  .end_boundary_align
> 
> p.s. If anyone has a better name than "boundary align" please suggest it.  That's not a good name; it's just a placeholder.

Do we need some option or syntax to disable ".boundary_align 4", so that the same code can be compiled for some machine that do not need align branch?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D71238/new/

https://reviews.llvm.org/D71238





More information about the llvm-commits mailing list