[PATCH] D71008: [DebugInfo] Refactored macro related generation, added a test case for macinfo.dwo emission.
Sourabh Singh Tomar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Dec 10 12:01:02 PST 2019
SouraVX marked an inline comment as done.
SouraVX added inline comments.
================
Comment at: llvm/test/DebugInfo/X86/debug-macro-split-dwarf.ll:67
+!20 = !DIMacro(type: DW_MACINFO_define, name: "__GNUC__", value: "4")
+!21 = !{i32 7, !"Dwarf Version", i32 5}
+!22 = !{i32 2, !"Debug Info Version", i32 3}
----------------
dblaikie wrote:
> SouraVX wrote:
> > @dblaikie are you suggesting to change DWARF version here, or renaming the test case it self to something like `debug-macinfo-split-dwarf.ll`.
> > Please note here, that their is a bit of inconsistency, I noticed a non-split DWARFv4 test case named as `debug-macro.ll` .
> > If that's what you're suggesting; then maybe we should also rename `debug-macro.ll` to `debug-macinfo.ll` for naming consistency and future addition of test cases.
> Yep, this is where I was suggesting changing the version.
>
> Yeah, at the time the debug-macro.ll test was written there was no debug_macro section, so there was no ambiguity (debug-macro obviously tested the debug_macinfo section), but now that there is, it may be somewhat confusing & could be renamed (don't do that in this patch though).
>
> Renaming this test before it's committed seems like a good idea to go with the version change, yes.
Thank you for clarifying this.
Sure will do this, before committing,
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D71008/new/
https://reviews.llvm.org/D71008
More information about the llvm-commits
mailing list