[PATCH] D70758: [PowerPC][NFC] Rename record instructions to use _record suffix instead of o
Justin Hibbits via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Dec 5 09:55:44 PST 2019
jhibbits added a comment.
I might object less to a _rec suffix. However, you would still need to understand what "record form" means, which requires understanding of the ISA. Why not simply add a comment block to the top of PPCInstrInfo.td, describing things like this? I have a feeling other newbies would have similar questions/concerns/complaints, and they can't all be addressed by renaming everything.
I would propose something along the lines of the following as a block comment in PPCInstrInfo.td:
The following conventions are used for PowerISA definitions:
- - 'o' suffix: Record-form of an instruction, updates CR
- - '8' suffix: 64-bit version of an instruction
These can be chained, such as in the case of 'ANDI8o'
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D70758/new/
https://reviews.llvm.org/D70758
More information about the llvm-commits
mailing list