[PATCH] D70485: [ARM,MVE] Add intrinsics to deal with predicates.

Simon Tatham via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Nov 21 09:16:10 PST 2019


simon_tatham added inline comments.


================
Comment at: llvm/include/llvm/IR/IntrinsicsARM.td:780
 
 def int_arm_vctp8  : Intrinsic<[llvm_v16i1_ty], [llvm_i32_ty], [IntrNoMem]>;
 def int_arm_vctp16 : Intrinsic<[llvm_v8i1_ty], [llvm_i32_ty], [IntrNoMem]>;
----------------
dmgreen wrote:
> Should we rename int_arm_vctp8 to int_arm_mve_vctp8?
Ha! What you mean by this and the next comment is "Simon, you are totally wrong when you claim in the commit message that these intrinsics are for NEON as well". :-)

I was misled myself by the lack of "mve" in the name. So yes, now I've found out that they //are// MVE-specific, I agree I should put it in!


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D70485/new/

https://reviews.llvm.org/D70485





More information about the llvm-commits mailing list