[PATCH] D67572: [VectorUtils] Introduce the Vector Function Database (VFDatabase).
Francesco Petrogalli via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Nov 20 07:08:29 PST 2019
fpetrogalli added inline comments.
================
Comment at: llvm/include/llvm/Analysis/VectorUtils.h:97
+ // HasGlobalPred.
+ static VFShape getFlatVF(const CallInst &CI, const unsigned VF,
+ const bool IsScalable, const bool HasGlobalPred) {
----------------
sdesmalen wrote:
> I don't really understand what you mean by a "flat" vectorization shape. Is this function supposed to return a 'widened' (vector version of a) function? If so, can we please rename this to `getVectorShapeForCall` ?
Yeah, the name is misleading. This is supposed to return a widenened version of the function... but I don't like the name `getVectorShapeForCall`, because a Shape for a Vector Call can have Linear modifiers for example, while this function is returning only the shape that uses `VFParamKind::Vector` for all `VFPArameter`s.
How about `getAllVectorsShape`?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67572/new/
https://reviews.llvm.org/D67572
More information about the llvm-commits
mailing list