[PATCH] D69474: AMDGPU: Avoid overwriting saved PC
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Oct 27 10:09:26 PDT 2019
arsenm added inline comments.
================
Comment at: llvm/lib/Target/AMDGPU/SIInsertWaitcnts.cpp:956
+
+ int CallDstOpIdx =
+ AMDGPU::getNamedOperandIdx(MI.getOpcode(), AMDGPU::OpName::dst);
----------------
This is a potentially confusing name. It's the return address operand
================
Comment at: llvm/lib/Target/AMDGPU/SIInsertWaitcnts.cpp:958
+ AMDGPU::getNamedOperandIdx(MI.getOpcode(), AMDGPU::OpName::dst);
+ if (CallDstOpIdx != -1) {
+ RegInterval DstInterval = ScoreBrackets.getRegInterval(&MI, TII, MRI, TRI,
----------------
This should never fail
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D69474/new/
https://reviews.llvm.org/D69474
More information about the llvm-commits
mailing list