[PATCH] D69432: [ARM][Thumb2InstrInfo]: fix default '0' opcode when rewriting frame indeces
David Tellenbach via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Oct 25 08:06:26 PDT 2019
tellenbach added inline comments.
================
Comment at: llvm/lib/Target/ARM/Thumb2InstrInfo.cpp:369
switch (opcode) {
+ default:
+ llvm_unreachable("unknown thumb2 opcode!");
----------------
Could you move the `default` case at the end of the `switch` statement? This makes it easier to follow the control-flow.
And please remove the exclamation mark `!`.
================
Comment at: llvm/lib/Target/ARM/Thumb2InstrInfo.cpp:399
switch (opcode) {
+ default:
+ llvm_unreachable("unknown thumb2 opcode!");
----------------
Same here
================
Comment at: llvm/lib/Target/ARM/Thumb2InstrInfo.cpp:429
switch (opcode) {
+ default:
+ llvm_unreachable("unknown thumb2 opcode!");
----------------
Same here
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D69432/new/
https://reviews.llvm.org/D69432
More information about the llvm-commits
mailing list