[PATCH] D69336: [Support] Make BitVector::BitWord size_t

Ehud Katz via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Oct 23 11:36:51 PDT 2019


ekatz marked an inline comment as done.
ekatz added inline comments.


================
Comment at: llvm/include/llvm/ADT/BitVector.h:74
 class BitVector {
-  typedef unsigned long BitWord;
+  typedef size_t BitWord;
 
----------------
lebedev.ri wrote:
> ekatz wrote:
> > lebedev.ri wrote:
> > > It may be better to split NFC cleanup (rest of the patch) and this change into two separate patches.
> > It is no cleanup, but the same change. It used to be `unsigned long`, and therefore the numbers (changed) had the suffix `UL` (unsigned long). As there is no appropriate suffix for `size_t`, we need to apply //casting// instead.
> I think the point i was making was missed.
> The suffix->cast cleanup is valid regardless, it can be done beforehand,
> and then this patch becomes a single line change.
OK, as there are already other places, in the current version, where the cast to `BitWord` is made, then this sounds reasonable. Is there a way to post 2 patches in a single review using Phabricator? Or should I open a separate review?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D69336/new/

https://reviews.llvm.org/D69336





More information about the llvm-commits mailing list