[PATCH] D69336: [Support] Make BitVector::BitWord size_t
Ehud Katz via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Oct 23 10:23:24 PDT 2019
ekatz marked an inline comment as done.
ekatz added inline comments.
================
Comment at: llvm/include/llvm/ADT/BitVector.h:74
class BitVector {
- typedef unsigned long BitWord;
+ typedef size_t BitWord;
----------------
lebedev.ri wrote:
> It may be better to split NFC cleanup (rest of the patch) and this change into two separate patches.
It is no cleanup, but the same change. It used to be `unsigned long`, and therefore the numbers (changed) had the suffix `UL` (unsigned long). As there is no appropriate suffix for `size_t`, we need to apply //casting// instead.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D69336/new/
https://reviews.llvm.org/D69336
More information about the llvm-commits
mailing list