[PATCH] D68290: [RISCV] WIP better estimate size of outlined block with C extension enabled
Lewis Revill via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Oct 3 09:06:17 PDT 2019
lewis-revill added a comment.
Hi Ana, I'm yet to try this out on our benchmarks, but it looks like a good implementation to me. Considering Alex's comments above, should this patch be reduced to just the isCompressible check and I can merge the rest into the machine outliner patch after adding this one as a parent?
================
Comment at: llvm/lib/Target/RISCV/RISCVInstrInfo.cpp:556
for (; I != E; ++I)
- SequenceSize += getInstSizeInBytes(*I);
+ if (isCompressableInst(*I, &ST, MRI, STI))
+ SequenceSize += 2;
----------------
Nitpick: this should be called isCompressibleInst (IE with an i rather than an a).
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68290/new/
https://reviews.llvm.org/D68290
More information about the llvm-commits
mailing list