[PATCH] D67920: [PGO] Refactor Value Profiling into a plugin based oracle and create a well defined API for the plugins.
Teresa Johnson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Sep 24 17:28:17 PDT 2019
tejohnson added a comment.
In general, I like the cleanup of extracting out the value profiling handling into a uniform API. I'm not convinced it needs something as complex as the plugin interface though, as opposed to a wrapper class that has an instance of each type and invokes the appropriate run() command given the requested profile type. Although perhaps there isn't a big downside of doing it that way either, not sure of the overhead of the resulting template instantiation.
Comment below about naming conventions.
================
Comment at: llvm/lib/Transforms/Instrumentation/ValueProfileOracle.cpp:35
+/// ValueProfileOracleImpl.
+using VPOPluginChain_t = VPOPluginChain<VPO_PLUGIN_LIST>;
+
----------------
LLVM coding conventions don't use underscores: https://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67920/new/
https://reviews.llvm.org/D67920
More information about the llvm-commits
mailing list