[PATCH] D67301: [LLD] Use the unified llvm demangle frontend function. NFC.
Martin Storsjö via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Sep 10 06:41:11 PDT 2019
mstorsjo updated this revision to Diff 219534.
mstorsjo retitled this revision from "[LLD] Unify the demangleItanium and demangleMSVC functions. NFC." to "[LLD] Use the unified llvm demangle frontend function. NFC.".
mstorsjo edited the summary of this revision.
mstorsjo added a reviewer: jhenderson.
mstorsjo added a comment.
Herald added subscribers: hiraditya, mgorny.
Updated to use the already unified llvm demangler frontend function, removing a lot of duplicated code in lld.
I'm adding another entry point to it, `Optional<std::string> tryDemangle(const std::string &MangledName)`, that easier allows distinguishing between whether it actually did demangle or not, used in the COFF code.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67301/new/
https://reviews.llvm.org/D67301
Files:
lld/COFF/CMakeLists.txt
lld/COFF/Symbols.cpp
lld/Common/CMakeLists.txt
lld/Common/Strings.cpp
lld/ELF/CMakeLists.txt
lld/ELF/SymbolTable.cpp
lld/ELF/Symbols.cpp
lld/include/lld/Common/Strings.h
lld/wasm/Symbols.cpp
lld/wasm/Symbols.h
lld/wasm/SyntheticSections.cpp
llvm/include/llvm/Demangle/Demangle.h
llvm/lib/Demangle/Demangle.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D67301.219534.patch
Type: text/x-patch
Size: 10532 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20190910/d7c10f83/attachment.bin>
More information about the llvm-commits
mailing list