[PATCH] D66750: [CodeGen] Introduce MachineBasicBlock::updatePHIs helper and use it. NFC

Bjorn Pettersson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 26 11:29:11 PDT 2019


bjope added inline comments.


================
Comment at: llvm/include/llvm/CodeGen/MachineBasicBlock.h:496-497
+  /// Update PHI nodes in this MBB to refer to ToMBB instead of FromMBB.
+  void updatePHIs(MachineBasicBlock *FromMBB,
+                  MachineBasicBlock *ToMBB);
+
----------------
arsenm wrote:
> I don't think updatePHIs is a good name for a public version of this. replacePhiPredecessorWith maybe?
True that. `replacePhiPredecessorWith` sounds good to me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D66750/new/

https://reviews.llvm.org/D66750





More information about the llvm-commits mailing list