[PATCH] D65240: [XCOFF][AIX] Generate symbol table entries with llvm-readobj

Hubert Tong via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 19 21:45:01 PDT 2019


hubert.reinterpretcast added inline comments.


================
Comment at: llvm/include/llvm/Object/XCOFFObjectFile.h:285
+  DataRefImpl SymEntDataRef;
+  const XCOFFObjectFile *OwningObjectPtr;
+
----------------
Make both fields `const` if we don't need to modify them.


================
Comment at: llvm/include/llvm/Object/XCOFFObjectFile.h:289
+  XCOFFSymbolRef(DataRefImpl SymEntDataRef,
+                 const XCOFFObjectFile *owningObjectPtr)
+      : SymEntDataRef(SymEntDataRef), OwningObjectPtr(owningObjectPtr){};
----------------
Parameter variable name does not match the prevalent style.


================
Comment at: llvm/include/llvm/Object/XCOFFObjectFile.h:294
+  uint8_t getNumberOfAuxEntries() const;
+  const XCOFFCSectAuxEnt *getXCoffCSectAuxEnt() const;
+  uint16_t getType() const;
----------------
There's no reason to add `XCoff` to the set of ways we capitalize XCOFF. We already use XCOFF even when we capitalize the next word in names.


================
Comment at: llvm/include/llvm/Object/XCOFFObjectFile.h:297
+  int16_t getSectionNumber() const;
+  bool hasCSectAuxEnt() const;
+  bool isFunction() const;
----------------
Newline before this to split the derived-property functions from the field accessors.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D65240/new/

https://reviews.llvm.org/D65240





More information about the llvm-commits mailing list